Recent activity

Voted 2 years ago
Rated the app at:
Commented 2 years ago
This is less of an issue and more of an FYI - the .php file still has the version listed as 1.2.0, so WordPress always complains that it needs updating released 1.4 so this shouldn't be an issue...
Voted 2 years ago
Rated the app at: